CVE-2017-7678 — spark-core_2.11
MEDIUMCVE-2017-7678 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.spark:spark-core_2.11. A fix is available for org.apache.spark:spark-core_2.11 — see the affected versions and patch details below.
Moderate severity vulnerability that affects org.apache.spark:spark-core_2.10 and org.apache.spark:spark-core_2.11
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.spark:spark-core_2.11☕org.apache.spark:spark-core_2.10Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Spark before 2.2.0, it is possible for an attacker to take advantage of a user's trust in the server to trick them into visiting a link that points to a shared Spark cluster and submits data including MHTML to the Spark master, or history server. This data, which could contain a script, would then be reflected back to the user and could be evaluated and executed by MS Windows-based clients. It is not an attack on Spark itself, but on the user, who may then execute the script inadvertently when viewing elements of the Spark web UIs.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.spark:spark-core_2.11 | all versions | 2.2.0org.apache.spark:spark-core_2.11:2.2.0 |
| ☕Maven | org.apache.spark:spark-core_2.10 | all versions | 2.2.0org.apache.spark:spark-core_2.10:2.2.0 |
Affected Products
sparkapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.spark:spark-core_2.11, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.spark:spark-core_2.11 to 2.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7678 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-7678 in your dependencies?
Find it across Maven, including transitive dependencies.