PocketMine-MP vulnerable to server crash using badly formatted sign NBT in BlockActorDataPacketGHSA-7wrv-6h42-w54f
HIGHFix: pmmp/PocketMine-MP@0c250a2GHSA-7wrv-6h42-w54f is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in pocketmine/pocketmine-mp. A fix is available for pocketmine/pocketmine-mp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-7wrv-6h42-w54f.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pocketmine/pocketmine-mp🐘pocketmine/pocketmine-mpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A player sending a packet can cause the server to crash by providing incorrect sign data in NBT in BlockActorDataPacket.
Details
This vulnerability was discovered using the BlockActorDataPacket, but other packets may also be affected. The player would seem to just need to send an NBT with an incorrect type to throw this error.
[Server thread/CRITICAL]: pocketmine\nbt\UnexpectedTagTypeException: "Expected a tag of type pocketmine\nbt\tag\CompoundTag, got pocketmine\nbt\tag\ByteTag" (EXCEPTION) in "pmsrc/vendor/pocketmine/nbt/src/tag/CompoundTag" at line 107
--- Stack trace ---
#0 pmsrc/src/network/mcpe/handler/InGamePacketHandler(751): pocketmine\nbt\tag\CompoundTag->getCompoundTag(string[9] FrontText)
#1 pmsrc/vendor/pocketmine/bedrock-protocol/src/BlockActorDataPacket(50): pocketmine\network\mcpe\handler\InGamePacketHandler->handleBlockActorData(object pocketmine\network\mcpe\protocol\BlockActorDataPacket#220241)
#2 pmsrc/src/network/mcpe/NetworkSession(433): pocketmine\network\mcpe\protocol\BlockActorDataPacket->handle(object pocketmine\network\mcpe\handler\InGamePacketHandler#190572)
PoC
Use a bot or proxy to send a packet when editing a sign. This packet should contain an NBT with incorrect types but correct architecture.
Impact
This makes it possible to shutdown a server for someone who knows how to operate it. As this was discovered in 4.22.1, everyone with at least this version is affected.
Patches
This bug was fixed by 0c250a2ef09627b48aa52302f6cc7e1f2afb70ea in the 4.22.3 and 5.2.1 releases.
Workarounds
A plugin may be able to handle DataPacketReceiveEvent for BlockActorDataPacket, and verify that the FrontText tag is a TAG_Compound.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | pocketmine/pocketmine-mp | ≥ 4.20.0&&< 4.22.3 | 4.22.3composer require pocketmine/pocketmine-mp:^4.22.3 |
| 🐘Packagist | pocketmine/pocketmine-mp | ≥ 5.0.0&&< 5.2.1 | 5.2.1composer require pocketmine/pocketmine-mp:^5.2.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pocketmine/pocketmine-mp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pocketmine/pocketmine-mp to 4.22.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7wrv-6h42-w54f is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-7wrv-6h42-w54f in your dependencies?
Find it across Packagist, including transitive dependencies.