October CMS Session ID not invalidated after logoutGHSA-7ggw-h8pp-r95r
CRITICALFix: octobercms/library@642f597GHSA-7ggw-h8pp-r95r is a critical-severity (CVSS 9.8) CWE-613 vulnerability in october/rain. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for october/rain — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/rain🐘october/rainReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When logging out, the session ID was not invalidated. This is not a problem while the user is logged out, but as soon as the user logs back in the old session ID would be valid again; which means that anyone that gained access to the old session cookie would be able to act as the logged in user. This is not a major concern for the majority of cases, since it requires a malicious party gaining access to the session cookie in the first place, but nevertheless has been fixed.
Patches
Issue has been patched in Build 472 (v1.0.472) and v1.1.2.
Workarounds
Apply https://github.com/octobercms/library/commit/642f597489e6f644d4bd9a0c267e864cabead024 to your installation manually if unable to upgrade to Build 472 or v1.1.2.
References
- Reported by Anisio (Brazilian Information Security Analyst)
- http://cve.circl.lu/cve/CVE-2021-3311
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Threat assessment:
<img width="699" alt="Screen Shot 2021-02-07 at 11 50 35 PM" src="https://user-images.githubusercontent.com/7253840/107180881-51eaf000-699f-11eb-8828-333128faf2a6.png">Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/rain | all versions | 1.0.472composer require october/rain:^1.0.472 |
| 🐘Packagist | october/rain | ≥ 1.1.0&&< 1.1.2 | 1.1.2composer require october/rain:^1.1.2 |
Affected Products
octoberoctobercmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/rain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/rain to 1.0.472 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7ggw-h8pp-r95r is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-7ggw-h8pp-r95r in your dependencies?
Find it across Packagist, including transitive dependencies.