GHSA-747v-52c4-8vj8 is a low-severity (CVSS 3.1) CWE-74 vulnerability in contao/core-bundle. A fix is available for contao/core-bundle — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-747v-52c4-8vj8.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
contao/core-bundle🐘contao/core-bundleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
It is possible to inject insert tags via the form generator if the submitted form data is output on the page in a specific way.
Patches
Update to Contao 4.13.40 or 5.3.4.
Workarounds
Do not output the submitted form data on the website.
References
https://contao.org/en/security-advisories/insert-tag-injection-via-the-form-generator
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/core-bundle | ≥ 4.0.0&&< 4.13.40 | 4.13.40composer require contao/core-bundle:^4.13.40 |
| 🐘Packagist | contao/core-bundle | ≥ 5.0.0-RC1&&< 5.3.4 | 5.3.4composer require contao/core-bundle:^5.3.4 |
Affected Products
contaocontaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/core-bundle to 4.13.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-747v-52c4-8vj8 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-747v-52c4-8vj8 in your dependencies?
Find it across Packagist, including transitive dependencies.