CVE-2024-28191 is a low-severity (CVSS 3.1) CWE-74 vulnerability in contao/core-bundle. A fix is available for contao/core-bundle — see the affected versions and patch details below.
Contao may have unencoded insert tags in the frontend
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28191.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
contao/core-bundle🐘contao/core-bundleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, it is possible to inject insert tags in frontend forms if the output is structured in a very specific way. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, do not output user data from frontend forms next to each other, always separate them by at least one character.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/core-bundle | ≥ 4.0.0&&< 4.13.40 | 4.13.40composer require contao/core-bundle:^4.13.40 |
| 🐘Packagist | contao/core-bundle | ≥ 5.0.0-RC1&&< 5.3.4 | 5.3.4composer require contao/core-bundle:^5.3.4 |
Affected Products
contaocontaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/core-bundle to 4.13.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28191 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-28191 in your dependencies?
Find it across Packagist, including transitive dependencies.