SEOmatic for CraftCMS allows Server-Side Template InjectionGHSA-6q4j-8pjm-5mgc
CRITICALFix: nystudio107/craft-seomatic@65ab659GHSA-6q4j-8pjm-5mgc is a critical-severity (CVSS 9.8) CWE-74 vulnerability in nystudio107/craft-seomatic. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nystudio107/craft-seomatic — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nystudio107/craft-seomaticReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Seomatic component before 3.2.46 for Craft CMS allows Server-Side Template Injection and information disclosure via malformed data to the metacontainers controller.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | nystudio107/craft-seomatic | all versions | 3.3.0composer require nystudio107/craft-seomatic:^3.3.0 |
Affected Products
craft cmscraftcmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nystudio107/craft-seomatic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nystudio107/craft-seomatic to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6q4j-8pjm-5mgc is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
How to detect GHSA-6q4j-8pjm-5mgc
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-6q4j-8pjm-5mgc -u https://target- Template
- Craft CMS < 3.3.0 - Server-Side Template Injection
- Severity
- critical
- Impact
- Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code on the server.
- Remediation
- Upgrade Craft CMS to version 3.3.0 or higher to mitigate this vulnerability.
Template by ProjectDiscovery nuclei-templates (dwisiswant0), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-6q4j-8pjm-5mgc in your dependencies?
Find it across Packagist, including transitive dependencies.