NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2021-44618 — craft-seomatic

CRITICALFix: nystudio107/craft-seomatic@0c5c0c0

CVE-2021-44618 is a critical-severity (CVSS 9.8) Code Injection vulnerability in nystudio107/craft-seomatic. A fix is available for nystudio107/craft-seomatic — see the affected versions and patch details below.

Server-side Template Injection in nystudio107/craft-seomatic

Also known asGHSA-m3xv-x3ph-mq22
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.01%0.64%1.27%1.90%0.5%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nystudio107/craft-seomatic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A Server-side Template Injection (SSTI) vulnerability exists in Nystudio107 Seomatic prior to 3.4.12 in src/helpers/UrlHelper.php via the host header.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnystudio107/craft-seomaticall versions3.4.12composer require nystudio107/craft-seomatic:^3.4.12

Affected Products

1 product · 1 configurations
Application
seomaticnystudio107
1 version
3.4.12

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nystudio107/craft-seomatic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nystudio107/craft-seomatic to 3.4.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-44618 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

A Server-side Template Injection (SSTI) vulnerability exists in Nystudio107 Seomatic prior to 3.4.12 in src/helpers/UrlHelper.php via the host header.
O3 Security · Impact-Aware SCA

Is CVE-2021-44618 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-44618: craft-seomatic — Fixed in 3.4.12