CVE-2021-41750 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in nystudio107/craft-seomatic. A fix is available for nystudio107/craft-seomatic — see the affected versions and patch details below.
Cross-site Scripting in SEOmatic plugin
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nystudio107/craft-seomaticReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A cross-site scripting (XSS) vulnerability in the SEOmatic plugin 3.4.10 for Craft CMS 3 allows remote attackers to inject arbitrary web script via a GET to /index.php?action=seomatic/file/seo-file-link with url parameter containing the base64 encoded URL of a malicious web page / file and fileName parameter containing an arbitrary filename with the intended content-type to be rendered in the user's browser as the extension.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | nystudio107/craft-seomatic | all versions | 3.4.11composer require nystudio107/craft-seomatic:^3.4.11 |
Affected Products
seomaticnystudio107Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nystudio107/craft-seomatic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nystudio107/craft-seomatic to 3.4.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-41750 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2021-41750 in your dependencies?
Find it across Packagist, including transitive dependencies.