NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2020-9757 — craft-seomatic

CRITICALFix: nystudio107/craft-seomatic@65ab659

CVE-2020-9757 is a critical-severity (CVSS 9.8) CWE-74 vulnerability in nystudio107/craft-seomatic. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nystudio107/craft-seomatic — see the affected versions and patch details below.

SEOmatic for CraftCMS allows Server-Side Template Injection

Also known asGHSA-6q4j-8pjm-5mgc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
72.8%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
66.4%77.6%88.8%100.0%94.3%72.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nystudio107/craft-seomatic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The SEOmatic component before 3.3.0 for Craft CMS allows Server-Side Template Injection that leads to RCE via malformed data to the metacontainers controller.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnystudio107/craft-seomaticall versions3.3.0composer require nystudio107/craft-seomatic:^3.3.0

Affected Products

1 product · 1 configurations
Application
craft cmscraftcms
< 3.3.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nystudio107/craft-seomatic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nystudio107/craft-seomatic to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-9757 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2020-9757

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2020-9757 -u https://target
Template
Craft CMS < 3.3.0 - Server-Side Template Injection
Severity
critical
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code on the server.
Remediation
Upgrade Craft CMS to version 3.3.0 or higher to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (dwisiswant0), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

The SEOmatic component before 3.3.0 for Craft CMS allows Server-Side Template Injection that leads to RCE via malformed data to the metacontainers controller.
O3 Security · Impact-Aware SCA

Is CVE-2020-9757 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-9757: craft-seomatic RCE — Fixed in 3.3.0