NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

High severity vulnerability that affects org.apache.tika:tika-coreGHSA-6jq2-789q-fff2

HIGH

GHSA-6jq2-789q-fff2 is a high-severity (CVSS 7.5) XML External Entity (XXE) vulnerability in org.apache.tika:tika-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tika:tika-core — see the affected versions and patch details below.

Also known asCVE-2018-11761
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
9.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
7.83%9.14%10.5%11.8%11.0%9.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.tika:tika-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Tika 0.1 to 1.18, the XML parsers were not configured to limit entity expansion. They were therefore vulnerable to an entity expansion vulnerability which can lead to a denial of service attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tika:tika-core≥ 0.1&&< 1.19.11.19.1org.apache.tika:tika-core:1.19.1

Affected Products

2 products · 3 configurations
Application
tikaapache
≥ 0.1 && ≤ 1.18
range
Application
business process management suiteoracle
2 versions
12.1.3.0.012.2.1.3.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tika:tika-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tika:tika-core to 1.19.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6jq2-789q-fff2 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

In Apache Tika 0.1 to 1.18, the XML parsers were not configured to limit entity expansion. They were therefore vulnerable to an entity expansion vulnerability which can lead to a denial of service attack.
O3 Security · Impact-Aware SCA

Is GHSA-6jq2-789q-fff2 in your dependencies?

Find it across Maven, including transitive dependencies.

High severity vulnerability that affects org.apache.tika:tika…