NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-66516 — tika-core

HIGH

CVE-2025-66516 is a high-severity (CVSS 8.4) XML External Entity (XXE) vulnerability in org.apache.tika:tika-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tika:tika-core — see the affected versions and patch details below.

Apache Tika core, Apache Tika parsers, Apache Tika PDF parser module: Update to CVE-2025-54988 to expand scope of artifacts affected

Also known asGHSA-f58c-gq56-vjjf
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
2 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-66516.

EPSS Exploitation Probability

via FIRST.org ↗
89.0%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%1.6%89.0%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.tika:tika-core☕org.apache.tika:tika-parsers☕org.apache.tika:tika-parser-pdf-module

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF.

This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways.

First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable.

Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tika:tika-core≥ 1.13&&< 3.2.23.2.2org.apache.tika:tika-core:3.2.2
☕Mavenorg.apache.tika:tika-parsers≥ 1.13&&< 2.0.02.0.0org.apache.tika:tika-parsers:2.0.0
☕Mavenorg.apache.tika:tika-parser-pdf-module≥ 2.0.0&&< 3.2.23.2.2org.apache.tika:tika-parser-pdf-module:3.2.2

Affected Products

1 product · 1 configurations
Application
tikaapache
≥ 1.13 && < 3.2.2
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tika:tika-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tika:tika-core to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-66516 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2025-66516

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2025-66516 -u https://target
Template
Apache Tika - XML External Entity Injection
Severity
high
Impact
Attackers can exploit XXE to read local files or cause denial of service, potentially exposing sensitive information or disrupting service.
Remediation
Upgrade tika-core to \u003E= 3.2.2 and ensure tika-pdf-module and tika-parsers are updated to latest versions.

Template by ProjectDiscovery nuclei-templates (MathematicianGoat), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatCritical

This vulnerability is rated Critical because it can be triggered when Apache Tika processes a maliciously crafted XFA file embedded within a PDF. Successful exploitation enables XML External Entity (XXE) injection, allowing an attacker to access sensitive local files and initiate arbitrary requests to internal or…

ProductFixed inAdvisory
Red Hat build of Apache Camel 4.14.2 for Spring Boot 3.5.8tika-coreRHSA-2025:23143
Red Hat OpenShift Dev Spaces (RHOSDS) 3.25devspaces/openvsx-rhel9:3.25.0-1765276570RHSA-2025:23225

Frequently Asked Questions

Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrad
O3 Security · Impact-Aware SCA

Is CVE-2025-66516 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-66516: tika-core XXE — Fixed in 3.2.2