CVE-2022-30126 is a medium-severity (CVSS 5.5) vulnerability in org.apache.tika:tika-core. A fix is available for org.apache.tika:tika-core — see the affected versions and patch details below.
Apache Tika Regular Expression Denial of Service in Standards Extractor
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tika:tika-core☕org.apache.tika:tika-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Tika, a regular expression in our StandardsText class, used by the StandardsExtractingContentHandler could lead to a denial of service caused by backtracking on a specially crafted file. This only affects users who are running the StandardsExtractingContentHandler, which is a non-standard handler.
This was originally fixed in 1.28.2 and 2.4.0. While the fix in version 2.4.0 was complete, the fix for the 1.x branch wasn't incorporated until version 1.28.3. Please see GHSA-qw3f-w4pf-jh5f for more information.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tika:tika-core | ≥ 1.17&&< 1.28.2 | 1.28.2org.apache.tika:tika-core:1.28.2 |
| ☕Maven | org.apache.tika:tika-core | ≥ 2.0.0&&< 2.4.0 | 2.4.0org.apache.tika:tika-core:2.4.0 |
Affected Products
tikaapacheprimavera unifieroracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tika:tika-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tika:tika-core to 1.28.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-30126 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.11 | tika-core | RHSA-2022:5532 |
Frequently Asked Questions
Is CVE-2022-30126 in your dependencies?
Find it across Maven, including transitive dependencies.