CVE-2019-10088 — tika-core
HIGHCVE-2019-10088 is a high-severity (CVSS 8.8) CWE-770 vulnerability in org.apache.tika:tika-core. A fix is available for org.apache.tika:tika-core — see the affected versions and patch details below.
Allocation of Resources Without Limits or Throttling in Apache Tika
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tika:tika-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Users should upgrade to 1.22 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tika:tika-core | ≥ 1.7&&< 1.22 | 1.22org.apache.tika:tika-core:1.22 |
Affected Products
tikaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tika:tika-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tika:tika-core to 1.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10088 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2019-10088 in your dependencies?
Find it across Maven, including transitive dependencies.