Exposure of Sensitive Information to an Unauthorized Actor in Apache KafkaGHSA-6jmf-mxwf-r3jc
HIGHGHSA-6jmf-mxwf-r3jc is a high-severity (CVSS 7.5) CWE-319 vulnerability in org.apache.kafka:kafka. A fix is available for org.apache.kafka:kafka — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kafka:kafka☕org.apache.kafka:kafka☕org.apache.kafka:kafka☕org.apache.kafka:kafkaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When Connect workers in Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, or 2.3.0 are configured with one or more config providers, and a connector is created/updated on that Connect cluster to use an externalized secret variable in a substring of a connector configuration property value, then any client can issue a request to the same Connect cluster to obtain the connector's task configuration and the response will contain the plaintext secret rather than the externalized secrets variables.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kafka:kafka | ≥ 2.0.0&&< 2.0.2 | 2.0.2org.apache.kafka:kafka:2.0.2 |
| ☕Maven | org.apache.kafka:kafka | ≥ 2.1.0&&< 2.1.2 | 2.1.2org.apache.kafka:kafka:2.1.2 |
| ☕Maven | org.apache.kafka:kafka | ≥ 2.2.0&&< 2.2.2 | 2.2.2org.apache.kafka:kafka:2.2.2 |
| ☕Maven | org.apache.kafka:kafka | ≥ 2.3.0&&< 2.3.1 | 2.3.1org.apache.kafka:kafka:2.3.1 |
Affected Products
kafkaapachebanking corporate lending process managementoraclebanking credit facilities process managementoraclebanking liquidity managementoraclebanking paymentsoraclebanking platformoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kafka:kafka, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kafka:kafka to 2.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6jmf-mxwf-r3jc is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Streams 1 | kafka | RHSA-2020:0939 |
Frequently Asked Questions
Is GHSA-6jmf-mxwf-r3jc in your dependencies?
Find it across Maven, including transitive dependencies.