CVE-2018-1288 — kafka
MEDIUMCVE-2018-1288 is a medium-severity (CVSS 5.4) vulnerability in org.apache.kafka:kafka. A fix is available for org.apache.kafka:kafka — see the affected versions and patch details below.
Improper Control of Generation of Code in Apache Kafka
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kafka:kafka☕org.apache.kafka:kafka☕org.apache.kafka:kafkaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Kafka 0.9.0.0 to 0.9.0.1, 0.10.0.0 to 0.10.2.1, 0.11.0.0 to 0.11.0.2, and 1.0.0, authenticated Kafka users may perform action reserved for the Broker via a manually created fetch request interfering with data replication, resulting in data loss.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kafka:kafka | ≥ 0.9.0.0&&< 0.10.2.2 | 0.10.2.2org.apache.kafka:kafka:0.10.2.2 |
| ☕Maven | org.apache.kafka:kafka | ≥ 0.11.0.0&&< 0.11.0.3 | 0.11.0.3org.apache.kafka:kafka:0.11.0.3 |
| ☕Maven | org.apache.kafka:kafka | ≥ 1.0.0&&< 1.0.1 | 1.0.1org.apache.kafka:kafka:1.0.1 |
Affected Products
kafkaapachedatabaseoracleprimavera p6 enterprise project portfolio managementoracletimesten in-memory databaseoraclejboss middleware text-only advisoriesredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kafka:kafka, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kafka:kafka to 0.10.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1288 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.2 | kafka | RHSA-2018:3768 |
Frequently Asked Questions
Is CVE-2018-1288 in your dependencies?
Find it across Maven, including transitive dependencies.