CVE-2022-34917 is a high-severity (CVSS 7.5) CWE-789 vulnerability in org.apache.kafka:kafka. A fix is available for org.apache.kafka:kafka — see the affected versions and patch details below.
Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-34917.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kafka:kafka☕org.apache.kafka:kafka☕org.apache.kafka:kafka☕org.apache.kafka:kafkaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. - Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. - Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kafka:kafka | ≥ 2.8.0&&< 2.8.2 | 2.8.2org.apache.kafka:kafka:2.8.2 |
| ☕Maven | org.apache.kafka:kafka | ≥ 3.0.0&&< 3.0.2 | 3.0.2org.apache.kafka:kafka:3.0.2 |
| ☕Maven | org.apache.kafka:kafka | ≥ 3.1.0&&< 3.1.2 | 3.1.2org.apache.kafka:kafka:3.1.2 |
| ☕Maven | org.apache.kafka:kafka | ≥ 3.2.0&&< 3.2.3 | 3.2.3org.apache.kafka:kafka:3.2.3 |
Affected Products
kafkaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kafka:kafka, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kafka:kafka to 2.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-34917 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Streams 2.2.0 | kafka | RHSA-2022:6819 |
Frequently Asked Questions
Is CVE-2022-34917 in your dependencies?
Find it across Maven, including transitive dependencies.