NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

SEOmatic plugin for Craft CMS SSTI VulnerabilityGHSA-6j9m-rp7m-3gfg

HIGHFix: nystudio107/craft-seomatic@1e7d1d0

GHSA-6j9m-rp7m-3gfg is a high-severity (CVSS 7.5) Code Injection vulnerability in nystudio107/craft-seomatic. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nystudio107/craft-seomatic — see the affected versions and patch details below.

Also known asCVE-2018-14716
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
32.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
24.3%39.2%54.1%69.0%60.6%32.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nystudio107/craft-seomatic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A Server Side Template Injection (SSTI) was discovered in the SEOmatic plugin before 3.1.4 for Craft CMS, because requests that don't match any elements incorrectly generate the canonicalUrl, and can lead to execution of Twig code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnystudio107/craft-seomaticall versions3.1.4composer require nystudio107/craft-seomatic:^3.1.4

Affected Products

1 product · 1 configurations
Application
seomaticnystudio107
< 3.1.4
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-45108webappslinux

Craft CMS SEOmatic plugin 3.1.4 - Server-Side Template Injection

by 0xB455 · Jul 31, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nystudio107/craft-seomatic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nystudio107/craft-seomatic to 3.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6j9m-rp7m-3gfg is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

A Server Side Template Injection (SSTI) was discovered in the SEOmatic plugin before 3.1.4 for Craft CMS, because requests that don't match any elements incorrectly generate the canonicalUrl, and can lead to execution of Twig code.
O3 Security · Impact-Aware SCA

Is GHSA-6j9m-rp7m-3gfg in your dependencies?

Find it across Packagist, including transitive dependencies.

SEOmatic plugin for Craft CMS SSTI Vulnerability (High 7.5)