phpBB allows CSRFGHSA-69q7-hww4-8pjq
MEDIUMGHSA-69q7-hww4-8pjq is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in phpbb/phpbb. A fix is available for phpbb/phpbb — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpbb/phpbbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
phpBB 3.2.8 allows a CSRF attack that can approve pending group memberships.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpbb/phpbb | all versions | 3.2.9composer require phpbb/phpbb:^3.2.9 |
Affected Products
phpbbphpbbDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpbb/phpbb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpbb/phpbb to 3.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-69q7-hww4-8pjq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-69q7-hww4-8pjq in your dependencies?
Find it across Packagist, including transitive dependencies.