NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Cross-site scripting (XSS) in Apache ActiveMQGHSA-66gw-ch5v-74v8

MEDIUMFix: apache/activemq@177eb71

GHSA-66gw-ch5v-74v8 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.activemq:activemq-parent. EPSS puts its 30-day exploitation probability at 79.0% (100th percentile). A fix is available for org.apache.activemq:activemq-parent — see the affected versions and patch details below.

Also known asBIT-activemq-2020-13947CVE-2020-13947
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
79.0%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%4.0%79.0%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.activemq:activemq-parent☕org.apache.activemq:activemq-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-parent≥ 5.16.0&&< 5.16.15.16.1org.apache.activemq:activemq-parent:5.16.1
☕Mavenorg.apache.activemq:activemq-parentall versions5.15.14org.apache.activemq:activemq-parent:5.15.14

Affected Products

3 products · 4 configurations
Application
activemqapache
≥ 5.16.0 && < 5.16.1
range
Application
communications session report manageroracle
≥ 8.0.0 && ≤ 8.2.2
range
Application
communications session route manageroracle
≥ 8.0.0 && ≤ 8.2.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-parent to 5.16.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-66gw-ch5v-74v8 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.
O3 Security · Impact-Aware SCA

Is GHSA-66gw-ch5v-74v8 in your dependencies?

Find it across Maven, including transitive dependencies.

Cross-site scripting (XSS) in Apache ActiveMQ