NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2017-15709 — activemq-openwire-generat…

LOWFix: apache/activemq@8ff18c5

CVE-2017-15709 is a low-severity (CVSS 3.7) Information Exposure vulnerability in org.apache.activemq:activemq-openwire-generator. EPSS puts its 30-day exploitation probability at 22.8% (98th percentile). A fix is available for org.apache.activemq:activemq-openwire-generator — see the affected versions and patch details below.

ActiveMQ's OpenWire protocol exposes certain system details as plain text

Also known asGHSA-7qm4-p377-fr2r
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
22.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
9.89%32.8%55.7%78.6%65.7%22.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.activemq:activemq-openwire-generator☕org.apache.activemq:activemq-parent☕org.apache.activemq:activemq-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

When using the OpenWire protocol in ActiveMQ versions 5.14.0 to 5.15.2 it was found that certain system details (such as the OS and kernel version) are exposed as plain text.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-openwire-generator≥ 5.14.0&&< 5.15.35.15.3org.apache.activemq:activemq-openwire-generator:5.15.3
☕Mavenorg.apache.activemq:activemq-parent≥ 5.15.0&&< 5.15.35.15.3org.apache.activemq:activemq-parent:5.15.3
☕Mavenorg.apache.activemq:activemq-parent≥ 5.14.0&&< 5.14.65.14.6org.apache.activemq:activemq-parent:5.14.6

Affected Products

1 product · 1 configurations
Application
activemqapache
≥ 5.14.0 && ≤ 5.15.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-openwire-generator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-openwire-generator to 5.15.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15709 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

When using the OpenWire protocol in ActiveMQ versions 5.14.0 to 5.15.2 it was found that certain system details (such as the OS and kernel version) are exposed as plain text.
O3 Security · Impact-Aware SCA

Is CVE-2017-15709 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-15709: activemq-openwire — Fixed in 5.15.3