CVE-2021-26117 is a high-severity (CVSS 7.5) Improper Authentication vulnerability in org.apache.activemq:activemq-parent. EPSS puts its 30-day exploitation probability at 11.3% (96th percentile). A fix is available for org.apache.activemq:activemq-parent — see the affected versions and patch details below.
Improper Authentication in Apache ActiveMQ and Apache Artemis
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:activemq-parent☕org.apache.activemq:activemq-parent☕org.apache.activemq:apache-artemisReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The optional ActiveMQ LDAP login module can be configured to use anonymous access to the LDAP server. In this case, for Apache ActiveMQ Artemis prior to version 2.16.0 and Apache ActiveMQ prior to versions 5.16.1 and 5.15.14, the anonymous context is used to verify a valid users password in error, resulting in no check on the password.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-parent | ≥ 5.16.0&&< 5.16.1 | 5.16.1org.apache.activemq:activemq-parent:5.16.1 |
| ☕Maven | org.apache.activemq:activemq-parent | all versions | 5.15.14org.apache.activemq:activemq-parent:5.15.14 |
| ☕Maven | org.apache.activemq:apache-artemis | all versions | 2.16.0org.apache.activemq:apache-artemis:2.16.0 |
Affected Products
activemqapacheartemisapachedebian linuxdebianoncommand workflow automationnetappcommunications element manageroraclecommunications session report manageroracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-parent to 5.16.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-26117 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
There is currently no known mitigation for this issue.Source: Red Hat security advisory for CVE-2021-26117 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ | see advisory | RHSA-2020:4154 |
| Red Hat AMQ | see advisory | RHSA-2020:5365 |
| Red Hat Fuse/AMQ 6.3.18 | broker | RHSA-2021:0384 |
Frequently Asked Questions
Is CVE-2021-26117 in your dependencies?
Find it across Maven, including transitive dependencies.