Apache Tomcat Uncontrolled Resource Consumption vulnerabilityGHSA-653p-vg55-5652
MEDIUMFix: apache/tomcat@f57a9d9GHSA-653p-vg55-5652 is a medium-severity (CVSS 5.3) Uncontrolled Resource Consumption vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-653p-vg55-5652.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.
This vulnerability does not affect core Apache Tomcat server components (tomcat-catalina, tomcat-coyote, tomcat-embed-core, etc.). Removing the webapps/examples/ directory in production environments — as recommended by the Apache Tomcat Security Considerations documentation — eliminates the attack surface entirely.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 11.0.0-M1&&< 11.0.2 | 11.0.2org.apache.tomcat:tomcat:11.0.2 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 10.1.0-M1&&< 10.1.34 | 10.1.34org.apache.tomcat:tomcat:10.1.34 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0.M1&&< 9.0.98 | 9.0.98org.apache.tomcat:tomcat:9.0.98 |
Affected Products
tomcatapachebootstrap osnetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 11.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-653p-vg55-5652 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
By default, the examples web application is only accessible to the localhost.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.36-1.el10_0 | RHSA-2025:7497 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.120-1.el8_10 | RHSA-2026:68677 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | tomcat-1:9.0.120-1.el8_8 | RHSA-2026:68680 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.110-2.el9_8 | RHSA-2026:18916 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_2 | RHSA-2026:68678 |
| Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_4 | RHSA-2026:68679 |
| Red Hat Enterprise Linux 9.6 Extended Update Support | tomcat-1:9.0.120-1.el9_6 | RHSA-2026:68659 |
Frequently Asked Questions
Is GHSA-653p-vg55-5652 in your dependencies?
Find it across Maven, including transitive dependencies.