NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Apache Tomcat has an Improper Authorization vulnerabilityGHSA-5v3h-fjv2-54fg

MEDIUMFix: apache/tomcat@3f6bd2b

GHSA-5v3h-fjv2-54fg is a medium-severity (CVSS 6.5) CWE-285 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.

Also known asBIT-tomcat-2026-55956CVE-2026-55956
Published
Updated
Affected
15 pkgs
Patched
9 / 15
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-5v3h-fjv2-54fg.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.68%1.35%2.03%0.2%0.7%Jul 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

15 pkgs affected
☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat+7 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.

Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

Affected Packages

15 total 9 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 11.0.0-M1&&< 11.0.2311.0.23org.apache.tomcat.embed:tomcat-embed-core:11.0.23
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 10.1.0-M1&&< 10.1.5610.1.56org.apache.tomcat.embed:tomcat-embed-core:10.1.56
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 9.0.0.M1&&< 9.0.1199.0.119org.apache.tomcat.embed:tomcat-embed-core:9.0.119
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 8.5.0No fix
☕Mavenorg.apache.tomcat.embed:tomcat-embed-coreall versionsNo fix
☕Mavenorg.apache.tomcat:tomcat≥ 11.0.0-M1&&< 11.0.2311.0.23org.apache.tomcat:tomcat:11.0.23

Affected Products

1 product · 3 configurations
Application
tomcatapache
≥ 11.0.0 && < 11.0.23
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat.embed:tomcat-embed-core to 11.0.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5v3h-fjv2-54fg is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

A security flaw in Apache Tomcat allows an attacker to bypass specific HTTP method restrictions on the default servlet. Red Hat products utilizing affected Tomcat versions are vulnerable if they rely on these method-specific security constraints. This could potentially enable unauthorized access to restricted…

Workaround published by Red Hat
Review your application's web.xml file. Ensure security constraints explicitly deny unauthorized users by path, rather than relying strictly on filtering specific HTTP methods (like GET or POST).
Source: Red Hat security advisory for GHSA-5v3h-fjv2-54fg (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 10tomcat9-1:9.0.120-1.el10_2RHSA-2026:68651
Red Hat Enterprise Linux 10.0 Extended Update Supporttomcat9-1:9.0.120-1.el10_0RHSA-2026:67163
Red Hat Enterprise Linux 8tomcat-1:9.0.120-1.el8_10RHSA-2026:68677
Red Hat Enterprise Linux 8.8 Telecommunications Update Servicetomcat-1:9.0.120-1.el8_8RHSA-2026:68680
Red Hat Enterprise Linux 9tomcat-1:9.0.120-2.el9_8RHSA-2026:68660
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_2RHSA-2026:68678
Red Hat Enterprise Linux 9.4 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_4RHSA-2026:68679
Red Hat Enterprise Linux 9.6 Extended Update Supporttomcat-1:9.0.120-1.el9_6RHSA-2026:68659

Frequently Asked Questions

Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
O3 Security · Impact-Aware SCA

Is GHSA-5v3h-fjv2-54fg in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Tomcat has an Improper Authorization vulnerability