NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

phpMyAdmin Cross-site Scripting In MySQL Table NameGHSA-5pvv-f8h3-gw96

Fix: phpmyadmin/phpmyadmin@212daad

GHSA-5pvv-f8h3-gw96 is a Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

Also known asCVE-2009-3696
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
2.07%2.68%3.28%3.88%3.4%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to inject arbitrary web script or HTML via a crafted name for a MySQL table.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 2.11.0&&< 2.11.9.62.11.9.6composer require phpmyadmin/phpmyadmin:^2.11.9.6
🐘Packagistphpmyadmin/phpmyadmin≥ 3.0.0&&< 3.2.2.13.2.2.1composer require phpmyadmin/phpmyadmin:^3.2.2.1

Affected Products

1 product · 69 configurations
Application
phpmyadminphpmyadmin
51 versions
2.11.02.11.0.02.11.0beta12.11.12.11.1.02.11.1.12.11.1.22.11.22.11.2.02.11.2.12.11.2.22.11.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 2.11.9.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5pvv-f8h3-gw96 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to inject arbitrary web script or HTML via a crafted name for a MySQL table.
O3 Security · Impact-Aware SCA

Is GHSA-5pvv-f8h3-gw96 in your dependencies?

Find it across Packagist, including transitive dependencies.

phpMyAdmin Cross-site Scripting In MySQL Table Name