CVE-2009-3696 — phpmyadmin
Fix: phpmyadmin/phpmyadmin@212daadCVE-2009-3696 is a Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
phpMyAdmin Cross-site Scripting In MySQL Table Name
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to inject arbitrary web script or HTML via a crafted name for a MySQL table.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 2.11.0&&< 2.11.9.6 | 2.11.9.6composer require phpmyadmin/phpmyadmin:^2.11.9.6 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 3.0.0&&< 3.2.2.1 | 3.2.2.1composer require phpmyadmin/phpmyadmin:^3.2.2.1 |
Affected Products
phpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 2.11.9.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-3696 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2009-3696 in your dependencies?
Find it across Packagist, including transitive dependencies.