Ansible Insertion of Sensitive Information into Log File vulnerabilityGHSA-588w-w6mv-3cw5
CRITICALFix: ansible/ansible@facbf7fGHSA-588w-w6mv-3cw5 is a critical-severity (CVSS 9.8) CWE-532 vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible🐍ansibleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible | ≥ 2.4.0.0&&< 2.4.1.0 | 2.4.1.0pip install --upgrade 'ansible==2.4.1.0' |
| 🐍PyPI | ansible | ≥ 2.3.0.0&&< 2.3.3.0 | 2.3.3.0pip install --upgrade 'ansible==2.3.3.0' |
Affected Products
ansibleredhatenterprise linux serverredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible to 2.4.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-588w-w6mv-3cw5 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat OpenStack Platform will no longer be updating the Ansible package in: * Red Hat OpenStack Platform 10 (Newton) * Red Hat OpenStack Platform 11 (Ocata) As of Red Hat Enterprise Linux 7.4, customers can consume an updated Ansible package directly from the extras-rhel-7.4 channel. For more information, refer to…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 Extras | ansible-0:2.4.0.0-5.el7 | RHSA-2017:2966 |
Frequently Asked Questions
Is GHSA-588w-w6mv-3cw5 in your dependencies?
Find it across PyPI, including transitive dependencies.