Denial of Service in Apache POIGHSA-523c-xh4g-mh5m
HIGHGHSA-523c-xh4g-mh5m is a high-severity (CVSS 7.5) CWE-835 vulnerability in org.apache.poi:poi. EPSS puts its 30-day exploitation probability at 10.1% (96th percentile). A fix is available for org.apache.poi:poi — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-523c-xh4g-mh5m.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.poi:poiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache POI in versions prior to release 3.17 are vulnerable to Denial of Service Attacks: 1) Infinite Loops while parsing crafted WMF, EMF, MSG and macros (POI bugs 61338 and 61294), and 2) Out of Memory Exceptions while parsing crafted DOC, PPT and XLS (POI bugs 52372 and 61295).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.poi:poi | all versions | 3.17org.apache.poi:poi:3.17 |
Affected Products
poiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.poi:poi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.poi:poi to 3.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-523c-xh4g-mh5m is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.3 | poi | RHSA-2018:1322 |
Frequently Asked Questions
Is GHSA-523c-xh4g-mh5m in your dependencies?
Find it across Maven, including transitive dependencies.