NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-9527 — poi

CVE-2014-9527 is a CWE-399 vulnerability in org.apache.poi:poi. A fix is available for org.apache.poi:poi — see the affected versions and patch details below.

Loop with Unreachable Exit Condition in Apache POI

Also known asGHSA-x9mm-6gpf-f749
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
0.00%3.31%6.62%9.93%1.2%6.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.poi:poi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

HSLFSlideShow in Apache POI before 3.11 allows remote attackers to cause a denial of service (infinite loop and deadlock) via a crafted PPT file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.poi:poiall versions3.11org.apache.poi:poi:3.11

Affected Products

2 products · 2 configurations
Application
poiapache
≤ 3.11
range
OS
fedorafedoraproject
1 version
20

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.poi:poi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.poi:poi to 3.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-9527 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss Data Virtualization 6.2apache-poiRHSA-2016:1135

Frequently Asked Questions

HSLFSlideShow in Apache POI before 3.11 allows remote attackers to cause a denial of service (infinite loop and deadlock) via a crafted PPT file.
O3 Security · Impact-Aware SCA

Is CVE-2014-9527 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-9527: poi DoS — Fixed in 3.11