NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-3574 — poi

CVE-2014-3574 is a security vulnerability in org.apache.poi:poi. A fix is available for org.apache.poi:poi — see the affected versions and patch details below.

Improper Input Validation in Apache POI

Also known asGHSA-5wfp-8643-c58x
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
5.47%8.38%11.3%14.2%11.1%7.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.poi:poi☕org.apache.poi:poi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.poi:poiall versions3.10.1org.apache.poi:poi:3.10.1
☕Mavenorg.apache.poi:poi≥ 3.11-beta1&&< 3.11-beta23.11-beta2org.apache.poi:poi:3.11-beta2

Affected Products

1 product · 65 configurations
Application
poiapache
≤ 3.10
37 versions
0.10.20.30.40.50.60.70.10.00.11.00.12.00.13.00.14.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.poi:poi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.poi:poi to 3.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3574 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Product Security has determined that CVE-2014-3574 is not exploitable by default in JBoss Portal Platform as provided by Red Hat. This flaw would only be exploitable if the Apache POI library provided by JBoss Portal Platform were used by a custom application to process user-supplied XML documents.

ProductFixed inAdvisory
Red Hat JBoss BPMS 6.0see advisoryRHSA-2014:1399
Red Hat JBoss BRMS 6.0see advisoryRHSA-2014:1400
Red Hat JBoss Data Virtualization 6.0apache-poiRHSA-2014:1398
Red Hat JBoss Fuse Service Works 6.0apache-poiRHSA-2014:1370
Red Hat JBoss Portal 6.2apache-poiRHSA-2015:1009

Frequently Asked Questions

Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.
O3 Security · Impact-Aware SCA

Is CVE-2014-3574 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3574: poi DoS — Fixed in 3.10.1