NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-3529 — poi

Fix: apache/poi@103b450

CVE-2014-3529 is a security vulnerability in org.apache.poi:poi. EPSS puts its 30-day exploitation probability at 12.8% (96th percentile). A fix is available for org.apache.poi:poi — see the affected versions and patch details below.

Improper Restriction of XML External Entity Reference in Apache POI

Also known asGHSA-q56h-jjj6-52mf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
12.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
2.82%7.10%11.4%15.7%5.2%12.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.poi:poi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary files via an OpenXML file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.poi:poiall versions3.10.1org.apache.poi:poi:3.10.1

Affected Products

1 product · 64 configurations
Application
poiapache
≤ 3.10
36 versions
0.10.20.30.40.50.60.70.10.00.11.00.12.00.13.00.14.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.poi:poi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.poi:poi to 3.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3529 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Product Security has determined that CVE-2014-3529 is not exploitable by default in JBoss Portal Platform as provided by Red Hat. This flaw would only be exploitable if the Apache POI library provided by JBoss Portal Platform were used by a custom application to process user-supplied XML documents.

ProductFixed inAdvisory
Red Hat JBoss BPMS 6.0see advisoryRHSA-2014:1399
Red Hat JBoss BRMS 6.0see advisoryRHSA-2014:1400
Red Hat JBoss Data Virtualization 6.0apache-poiRHSA-2014:1398
Red Hat JBoss Fuse Service Works 6.0apache-poiRHSA-2014:1370
Red Hat JBoss Portal 6.2apache-poiRHSA-2015:1009

Frequently Asked Questions

The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary files via an OpenXML file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
O3 Security · Impact-Aware SCA

Is CVE-2014-3529 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3529: poi XXE — Fixed in 3.10.1