NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

Active Record Improper Input ValidationGHSA-3crr-9vmg-864v

GHSA-3crr-9vmg-864v is a Improper Input Validation vulnerability in activerecord. A fix is available for activerecord — see the affected versions and patch details below.

Also known asCVE-2013-1854
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
1.28%2.19%3.11%4.02%1.8%3.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
💎activerecord💎activerecord💎activerecord

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The Active Record component in Ruby on Rails 2.3.x before 2.3.18, 3.1.x before 3.1.12, and 3.2.x before 3.2.13 processes certain queries by converting hash keys to symbols, which allows remote attackers to cause a denial of service via crafted input to a where method.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsactiverecord≥ 2.3.0&&< 2.3.182.3.18bundle update activerecord --conservative
💎RubyGemsactiverecord≥ 3.1.0&&< 3.1.123.1.12bundle update activerecord --conservative
💎RubyGemsactiverecord≥ 3.2.0&&< 3.2.133.2.13bundle update activerecord --conservative

Affected Products

3 products · 62 configurations
OS
enterprise linuxredhat
1 version
6.0
Application
railsrubyonrails
37 versions
2.3.02.3.12.3.22.3.32.3.42.3.92.3.102.3.112.3.122.3.132.3.142.3.15
Application
ruby on railsrubyonrails
2 versions
2.3.173.1.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for activerecord, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update activerecord to 2.3.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3crr-9vmg-864v is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Subscription Asset Manager 1.4katello-0:1.4.3.28-1.el6sam_spliceRHSA-2014:1863
RHEL 6 Version of OpenShift Enterpriseruby193-rubygem-activerecord-1:3.2.8-6.el6RHSA-2013:0699

Frequently Asked Questions

The Active Record component in Ruby on Rails 2.3.x before 2.3.18, 3.1.x before 3.1.12, and 3.2.x before 3.2.13 processes certain queries by converting hash keys to symbols, which allows remote attackers to cause a denial of service via crafted input to a where method.
O3 Security · Impact-Aware SCA

Is GHSA-3crr-9vmg-864v in your dependencies?

Find it across RubyGems, including transitive dependencies.

Active Record Improper Input Validation