CVE-2012-2695 — activerecord
Fix: rails/rails@62f81f4CVE-2012-2695 is a SQL Injection vulnerability in activerecord. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for activerecord — see the affected versions and patch details below.
activerecord vulnerable to SQL Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
activerecord💎activerecord💎activerecord💎activerecordReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The Active Record component in Ruby on Rails efore 2.3.15, 3.0.x before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage improper handling of nested hashes, a related issue to CVE-2012-2661.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | activerecord | ≥ 3.0.0.beta&&< 3.0.14 | 3.0.14bundle update activerecord --conservative |
| 💎RubyGems | activerecord | ≥ 3.1.0&&< 3.1.6 | 3.1.6bundle update activerecord --conservative |
| 💎RubyGems | activerecord | ≥ 3.2.0&&< 3.2.6 | 3.2.6bundle update activerecord --conservative |
| 💎RubyGems | activerecord | all versions | 2.3.15bundle update activerecord --conservative |
Affected Products
railsrubyonrailsruby on railsrubyonrailsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for activerecord, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update activerecord to 3.0.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-2695 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms for RHEL 6 | converge-ui-devel-0:1.0.4-1.el6cf | RHSA-2012:1542 |
| Red Hat Subscription Asset Manager 1.1 | rubygem-actionpack-1:3.0.10-11.el6cf | RHSA-2013:0154 |
| RHEL 6 Version of OpenShift Enterprise | graphviz-0:2.26.0-10.el6 | RHSA-2013:0582 |
Frequently Asked Questions
Is CVE-2012-2695 in your dependencies?
Find it across RubyGems, including transitive dependencies.