NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2014-3514 — activerecord

CVE-2014-3514 is a CWE-264 vulnerability in activerecord. A fix is available for activerecord — see the affected versions and patch details below.

Active Record subject to strong parameters protection bypass

Also known asGHSA-9rf5-jm6f-2fmm
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%1.18%2.36%3.54%0.3%2.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
💎activerecord💎activerecord

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

activerecord/lib/active_record/relation/query_methods.rb in Active Record in Ruby on Rails 4.0.x before 4.0.9 and 4.1.x before 4.1.5 allows remote attackers to bypass the strong parameters protection mechanism via crafted input to an application that makes create_with calls.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsactiverecord≥ 4.0.0&&< 4.0.94.0.9bundle update activerecord --conservative
💎RubyGemsactiverecord≥ 4.1.0&&< 4.1.54.1.5bundle update activerecord --conservative

Affected Products

1 product · 28 configurations
Application
railsrubyonrails
14 versions
4.0.04.0.14.0.24.0.34.0.44.0.54.0.64.0.74.0.84.1.04.1.14.1.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for activerecord, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update activerecord to 4.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3514 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Software Collections 1 for Red Hat Enterprise Linux 6ror40-rubygem-activerecord-1:4.0.2-2.3.el6RHSA-2014:1102

Frequently Asked Questions

activerecord/lib/active_record/relation/query_methods.rb in Active Record in Ruby on Rails 4.0.x before 4.0.9 and 4.1.x before 4.1.5 allows remote attackers to bypass the strong parameters protection mechanism via crafted input to an application that makes create_with calls.
O3 Security · Impact-Aware SCA

Is CVE-2014-3514 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2014-3514: activerecord — Fixed in 4.0.9