NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-50229 — tomcat

MEDIUMFix: apache/tomcat@0d5bdd5

CVE-2026-50229 is a medium-severity (CVSS 6.1) CWE-80 vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.

Apache Tomcat: XSS in number guess example

Also known asBIT-tomcat-2026-50229GHSA-pg42-rg8c-j886
Published
Updated
Affected
5 pkgs
Patched
3 / 5
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-50229.

EPSS Exploitation Probability

via FIRST.org ↗
4.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%1.82%3.65%5.47%0.2%4.1%Jul 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the number guess example for Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.

Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

Affected Packages

5 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat≥ 11.0.0-M1&&< 11.0.2311.0.23org.apache.tomcat:tomcat:11.0.23
☕Mavenorg.apache.tomcat:tomcat≥ 10.1.0-M1&&< 10.1.5610.1.56org.apache.tomcat:tomcat:10.1.56
☕Mavenorg.apache.tomcat:tomcat≥ 9.0.0.M1&&< 9.0.1199.0.119org.apache.tomcat:tomcat:9.0.119
☕Mavenorg.apache.tomcat:tomcat≥ 8.5.0No fix
☕Mavenorg.apache.tomcat:tomcatall versionsNo fix

Affected Products

1 product · 5 configurations
Application
tomcatapache
≥ 11.0.0 && ≤ 8.5.100
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat to 11.0.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-50229 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2026-50229

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2026-50229 -u https://target
Template
Apache Tomcat - Cross-Site Scripting
Severity
medium
Impact
Remote attackers can execute scripts in users' browsers, potentially stealing cookies or performing actions on behalf of users.
Remediation
Upgrade to versions 11.0.23, 10.1.56, or 9.0.119 or later.

Template by ProjectDiscovery nuclei-templates (yshahinzadeh, amirmsafari), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

A flaw was found in Apache Tomcat. A Cross-Site Scripting (XSS) vulnerability exists in the "number guess" example web application shipped with Tomcat. An attacker can inject malicious scripts into the example page, which execute in other users' browsers when they view the page. This vulnerability only affects the…

Workaround published by Red Hat
Remove or disable the Tomcat example web applications if they are deployed. Example applications are not needed for production use and should not be accessible in production environments.
Source: Red Hat security advisory for CVE-2026-50229 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 10tomcat9-1:9.0.120-1.el10_2RHSA-2026:68651
Red Hat Enterprise Linux 10.0 Extended Update Supporttomcat9-1:9.0.120-1.el10_0RHSA-2026:67163
Red Hat Enterprise Linux 8tomcat-1:9.0.120-1.el8_10RHSA-2026:68677
Red Hat Enterprise Linux 8.8 Telecommunications Update Servicetomcat-1:9.0.120-1.el8_8RHSA-2026:68680
Red Hat Enterprise Linux 9tomcat-1:9.0.120-2.el9_8RHSA-2026:68660
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_2RHSA-2026:68678
Red Hat Enterprise Linux 9.4 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_4RHSA-2026:68679
Red Hat Enterprise Linux 9.6 Extended Update Supporttomcat-1:9.0.120-1.el9_6RHSA-2026:68659

Frequently Asked Questions

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the number guess example for Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-50229 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-50229: tomcat XSS — Fixed in 11.0.23