CVE-2026-49289 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in simplesamlphp/saml2. A fix is available for simplesamlphp/saml2 — see the affected versions and patch details below.
SimpleSAMLphp SAML2: Possible DoS via XPath Transform
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
simplesamlphp/saml2🐘simplesamlphp/saml2-legacy🐘simplesamlphp/saml2🐘simplesamlphp/saml2-legacyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. In 4.19.2 and 4.20.2, the library permits attacker-controlled XPath transforms while processing XML signatures in specially crafted SAML messages. XPath evaluation can consume uncontrolled processing resources, allowing a remote unauthenticated attacker to deny service to any entity relying on SimpleSAMLphp or directly on the SAML2 library. The mitigation limits the number of transforms, permits only transform algorithms identified by the SAML 2.0 Core specification, and specifically rejects XPath transforms. This issue is fixed in versions 4.19.3 and 4.20.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | simplesamlphp/saml2 | ≥ 4.20.0&&< 4.20.3 | 4.20.3composer require simplesamlphp/saml2:^4.20.3 |
| 🐘Packagist | simplesamlphp/saml2-legacy | ≥ 4.20.0&&< 4.20.3 | 4.20.3composer require simplesamlphp/saml2-legacy:^4.20.3 |
| 🐘Packagist | simplesamlphp/saml2 | all versions | 4.19.3composer require simplesamlphp/saml2:^4.19.3 |
| 🐘Packagist | simplesamlphp/saml2-legacy | all versions | 4.19.3composer require simplesamlphp/saml2-legacy:^4.19.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simplesamlphp/saml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update simplesamlphp/saml2 to 4.20.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-49289 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2026-49289 in your dependencies?
Find it across Packagist, including transitive dependencies.