CVE-2018-7644 — saml2
HIGHCVE-2018-7644 is a high-severity (CVSS 7.5) CWE-347 vulnerability in simplesamlphp/saml2. A fix is available for simplesamlphp/saml2 — see the affected versions and patch details below.
SimpleSAMLphp Improper Verification of Cryptographic Signature
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
simplesamlphp/saml2🐘simplesamlphp/saml2🐘simplesamlphp/saml2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | simplesamlphp/saml2 | all versions | 1.10.5composer require simplesamlphp/saml2:^1.10.5 |
| 🐘Packagist | simplesamlphp/saml2 | ≥ 2.0&&< 2.3.7 | 2.3.7composer require simplesamlphp/saml2:^2.3.7 |
| 🐘Packagist | simplesamlphp/saml2 | ≥ 3.0&&< 3.1.3 | 3.1.3composer require simplesamlphp/saml2:^3.1.3 |
Affected Products
simplesamlphpsimplesamlphpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simplesamlphp/saml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update simplesamlphp/saml2 to 1.10.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-7644 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-7644 in your dependencies?
Find it across Packagist, including transitive dependencies.