NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2016-9814 — saml2

CRITICAL

CVE-2016-9814 is a critical-severity (CVSS 9.1) CWE-399 vulnerability in simplesamlphp/saml2. A fix is available for simplesamlphp/saml2 — see the affected versions and patch details below.

SimpleSAMLphp SAML2 spoof SAML responses

Also known asGHSA-r8v4-7vwj-983x
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.33%1.19%2.06%2.92%0.8%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘simplesamlphp/saml2🐘simplesamlphp/saml2🐘simplesamlphp/saml2🐘simplesamlphp/saml2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsimplesamlphp/saml2≥ 1.10&&< 1.10.31.10.3composer require simplesamlphp/saml2:^1.10.3
🐘Packagistsimplesamlphp/saml2all versions1.8.1composer require simplesamlphp/saml2:^1.8.1
🐘Packagistsimplesamlphp/saml2≥ 1.9.0&&< 1.9.11.9.1composer require simplesamlphp/saml2:^1.9.1
🐘Packagistsimplesamlphp/saml2≥ 2.0&&< 2.3.32.3.3composer require simplesamlphp/saml2:^2.3.3

Affected Products

2 products · 13 configurations
Application
saml2simplesamlphp
≤ 1.9
10 versions
1.101.10.11.10.22.0.02.0.12.12.22.32.3.12.3.2
Application
simplesamlphpsimplesamlphp
≤ 1.14.9
1 version
1.10

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simplesamlphp/saml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update simplesamlphp/saml2 to 1.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9814 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.
O3 Security · Impact-Aware SCA

Is CVE-2016-9814 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-9814: saml2 DoS — Fixed in 1.10.3