CVE-2018-6519 — saml2
HIGHCVE-2018-6519 is a high-severity (CVSS 7.5) CWE-74 vulnerability in simplesamlphp/saml2. A fix is available for simplesamlphp/saml2 — see the affected versions and patch details below.
SimpleSAMLphp SAML2 library Regular Expression Denial of Service vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
simplesamlphp/saml2🐘simplesamlphp/saml2🐘simplesamlphp/saml2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | simplesamlphp/saml2 | all versions | 1.10.4composer require simplesamlphp/saml2:^1.10.4 |
| 🐘Packagist | simplesamlphp/saml2 | ≥ 2.0&&< 2.3.5 | 2.3.5composer require simplesamlphp/saml2:^2.3.5 |
| 🐘Packagist | simplesamlphp/saml2 | ≥ 3.0&&< 3.1.1 | 3.1.1composer require simplesamlphp/saml2:^3.1.1 |
Affected Products
debian linuxdebiansaml2simplesamlphpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simplesamlphp/saml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update simplesamlphp/saml2 to 1.10.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-6519 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2018-6519 in your dependencies?
Find it across Packagist, including transitive dependencies.