NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2026-48820 — cakephp

CVE-2026-48820 is a Path Traversal vulnerability in cakephp/cakephp. A fix is available for cakephp/cakephp — see the affected versions and patch details below.

CakePHP: View::element() is missing a path containment check

Also known asGHSA-wpvj-hjcr-h3p2
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-48820.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.11%
Lower risk than most CVEs18th percentile — riskier than 18% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.3%0.3%0.3%0.4%0.3%Jul 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected
🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the application/plugin view template paths. When element names are created with specifically crafted user-supplied data this weakness can be leveraged to include other PHP files on the server. Patched releases are available in 5.3.6, 5.2.13, 5.1.7, 4.6.4, and 4.5.11.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcakephp/cakephp≥ 5.3.0&&< 5.3.65.3.6composer require cakephp/cakephp:^5.3.6
🐘Packagistcakephp/cakephp≥ 5.2.0&&< 5.2.135.2.13composer require cakephp/cakephp:^5.2.13
🐘Packagistcakephp/cakephp≥ 5.0.0&&< 5.1.75.1.7composer require cakephp/cakephp:^5.1.7
🐘Packagistcakephp/cakephp≥ 4.6.0&&< 4.6.44.6.4composer require cakephp/cakephp:^4.6.4
🐘Packagistcakephp/cakephpall versions4.5.11composer require cakephp/cakephp:^4.5.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cakephp/cakephp to 5.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-48820 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the application/plugin view template paths. When element names are created with specifically crafted user-supplied data this weakness can be leveraged to include other PHP files on the server. Patched releases are available in 5.3.6, 5.2.13, 5.1.7, 4.6.4, and 4.5.11.
O3 Security · Impact-Aware SCA

Is CVE-2026-48820 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-48820: cakephp — Fixed in 5.3.6