CakePHP: View::element() is missing a path containment checkGHSA-wpvj-hjcr-h3p2
GHSA-wpvj-hjcr-h3p2 is a Path Traversal vulnerability in cakephp/cakephp. A fix is available for cakephp/cakephp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-wpvj-hjcr-h3p2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the application/plugin view template paths. When element names are created with specifically crafted user-supplied data this weakness can be leveraged to include other PHP files on the server. Patched releases are available in 5.3.6, 5.2.13, 5.1.7, 4.6.4, and 4.5.11.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | cakephp/cakephp | ≥ 5.3.0&&< 5.3.6 | 5.3.6composer require cakephp/cakephp:^5.3.6 |
| 🐘Packagist | cakephp/cakephp | ≥ 5.2.0&&< 5.2.13 | 5.2.13composer require cakephp/cakephp:^5.2.13 |
| 🐘Packagist | cakephp/cakephp | ≥ 5.0.0&&< 5.1.7 | 5.1.7composer require cakephp/cakephp:^5.1.7 |
| 🐘Packagist | cakephp/cakephp | ≥ 4.6.0&&< 4.6.4 | 4.6.4composer require cakephp/cakephp:^4.6.4 |
| 🐘Packagist | cakephp/cakephp | all versions | 4.5.11composer require cakephp/cakephp:^4.5.11 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cakephp/cakephp to 5.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wpvj-hjcr-h3p2 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-wpvj-hjcr-h3p2 in your dependencies?
Find it across Packagist, including transitive dependencies.