NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CakePHP allows direct access of prefixed controller actionsGHSA-6hg4-vp5q-47mw

Fix: cakephp/cakephp@056f24a

GHSA-6hg4-vp5q-47mw is a security vulnerability in cakephp/cakephp. A fix is available for cakephp/cakephp — see the affected versions and patch details below.

Published
Updated
Affected
8 pkgs
Patched
8 / 8
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

8 pkgs affected
🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Unconventional URL paths would allow direct access to prefixed actions without setting the correct request parameters.

Affected Packages

8 total 8 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcakephp/cakephp≥ 2.0.0&&< 2.0.992.0.99composer require cakephp/cakephp:^2.0.99
🐘Packagistcakephp/cakephp≥ 2.1.0&&< 2.1.992.1.99composer require cakephp/cakephp:^2.1.99
🐘Packagistcakephp/cakephp≥ 2.2.0&&< 2.2.992.2.99composer require cakephp/cakephp:^2.2.99
🐘Packagistcakephp/cakephp≥ 2.3.0&&< 2.3.992.3.99composer require cakephp/cakephp:^2.3.99
🐘Packagistcakephp/cakephp≥ 2.4.0&&< 2.4.992.4.99composer require cakephp/cakephp:^2.4.99
🐘Packagistcakephp/cakephp≥ 2.5.0&&< 2.5.92.5.9composer require cakephp/cakephp:^2.5.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cakephp/cakephp to 2.0.99 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6hg4-vp5q-47mw is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Unconventional URL paths would allow direct access to prefixed actions without setting the correct request parameters.
O3 Security · Impact-Aware SCA

Is GHSA-6hg4-vp5q-47mw in your dependencies?

Find it across Packagist, including transitive dependencies.

CakePHP allows direct access of prefixed controller actions