CakePHP SecurityComponent cross form submission issueGHSA-j9q2-f9q7-jhgq
Fix: cakephp/cakephp@f23d811GHSA-j9q2-f9q7-jhgq is a security vulnerability in cakephp/cakephp. A fix is available for cakephp/cakephp — see the affected versions and patch details below.
Real-World Exposure
cakephp/cakephp🐘cakephp/cakephpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Prior to versions 2.4.8 and 1.3.18, forms secured by SecurityComponent could be submitted to any action without triggering SecurityComponent’s tampering protection. If an application contained multiple POST forms to manipulate the same models, it could be vulnerable to mass assignment issues.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | cakephp/cakephp | ≥ 2.0.0&&< 2.4.8 | 2.4.8composer require cakephp/cakephp:^2.4.8 |
| 🐘Packagist | cakephp/cakephp | ≥ 1.3.0&&< 1.3.18 | 1.3.18composer require cakephp/cakephp:^1.3.18 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cakephp/cakephp to 2.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j9q2-f9q7-jhgq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-j9q2-f9q7-jhgq in your dependencies?
Find it across Packagist, including transitive dependencies.