NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2026-42510 — ironic

MEDIUM

CVE-2026-42510 is a medium-severity (CVSS 6.6) CWE-829 vulnerability in ironic. A fix is available for ironic — see the affected versions and patch details below.

OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

Also known asGHSA-wqpv-c3pp-3m58PYSEC-2026-2525
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42510.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ironic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIironicall versions35.0.1pip install --upgrade 'ironic==35.0.1'

Affected Products

1 product · 4 configurations
Application
ironicopenstack
≥ 33.0.0 && < 35.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ironic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ironic to 35.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-42510 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
To mitigate this issue, avoid enabling the console interface in OpenStack Ironic if it is not strictly required for your operational needs. If the console interface is enabled, ensure that access to the OpenStack Ironic service is restricted to trusted administrative networks to prevent unauthorized `ipmitool` command execution. Any changes to Ironic configuration may require a service restart to take effect, which could impact ongoing bare metal provisioning operations.
Source: Red Hat security advisory for CVE-2026-42510 (CC BY 4.0)

Frequently Asked Questions

OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
O3 Security · Impact-Aware SCA

Is CVE-2026-42510 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-42510: ironic — Fixed in 35.0.1