NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-4985 — ironic

HIGHFix: openstack/ironic@426a306

CVE-2016-4985 is a high-severity (CVSS 7.5) Information Exposure vulnerability in ironic. A fix is available for ironic — see the affected versions and patch details below.

OpenStack Ironic Exposure of Sensitive Information to an Unauthorized Actor

Also known asGHSA-f7cr-7c2c-fm8rPYSEC-2026-646
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.16%1.27%2.38%3.48%0.8%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍ironic🐍ironic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVER_NAME/vendor_passthru resource.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIironicall versions4.2.5pip install --upgrade 'ironic==4.2.5'
🐍PyPIironic≥ 5.0&&< 5.1.25.1.2pip install --upgrade 'ironic==5.1.2'

Affected Products

2 products · 5 configurations
Application
openstack ironiccanonical
≤ 4.2.4
2 versions
5.1.05.1.1
Application
openstackredhat
2 versions
7.08

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ironic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ironic to 4.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4985 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7openstack-ironic-0:2015.1.2-4.el7ostRHSA-2016:1377
Red Hat OpenStack Platform 8.0 (Liberty)openstack-ironic-1:4.2.5-1.el7ostRHSA-2016:1378

Frequently Asked Questions

The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVER_NAME/vendor_passthru resource.
O3 Security · Impact-Aware SCA

Is CVE-2016-4985 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-4985: ironic Info Disclosure — Fixed in 4.2.5