NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2024-47211 — ironic

MEDIUMFix: openstack/ironic@2127cc4

CVE-2024-47211 is a medium-severity (CVSS 5.3) vulnerability in ironic. A fix is available for ironic — see the affected versions and patch details below.

OpenStack Ironic fails to verify checksums of supplied image_source URLs

Also known asGHSA-8h22-6qwx-q4w9PYSEC-2026-1468
Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47211.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.78%1.16%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐍ironic🐍ironic🐍ironic🐍ironic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In OpenStack Ironic before 21.4.4, 22.x and 23.x before 23.0.3, 23.x and 24.x before 24.1.3, and 25.x and 26.x before 26.1.0, there is a lack of checksum validation of supplied image_source URLs when configured to convert images to a raw format for streaming.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIironic≥ 25.0.0&&< 26.1.126.1.1pip install --upgrade 'ironic==26.1.1'
🐍PyPIironic≥ 23.1.0&&< 24.1.324.1.3pip install --upgrade 'ironic==24.1.3'
🐍PyPIironic≥ 22.0.0&&< 23.0.323.0.3pip install --upgrade 'ironic==23.0.3'
🐍PyPIironicall versionsNo fix

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ironic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ironic to 26.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47211 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This vulnerability is classified as moderate severity rather than important because it requires a specific set of conditions for exploitation. An attacker must have access to the image source and be positioned to intercept or modify images during their transmission, which limits the attack surface to environments with…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-47211 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 4.16openshift4/ose-ironic-rhel9:v4.16.0-202410221305.p0.g38becaa.assembly.stream.el9RHSA-2024:8415
Red Hat OpenShift Container Platform 4.17openshift4/ose-ironic-rhel9:v4.17.0-202410161235.p0.g90a9bc5.assembly.stream.el9RHSA-2024:8229
Red Hat OpenShift Container Platform 4.18openshift4/aws-kms-encryption-provider-rhel9:v4.18.0-202501230001.p0.g088dcaf.assembly.stream.el9RHSA-2024:6122
Red Hat OpenStack Platform 17.1 for RHEL 9openstack-ironic-1:17.1.1-17.1.20241122190825.c31db88.el9ostRHSA-2025:3482
Red Hat OpenStack Services on OpenShift 18.0openstack-ironic-1:21.4.5-18.0.20241207142602.9213ccd.el9ostRHSA-2025:0439

Frequently Asked Questions

In OpenStack Ironic before 21.4.4, 22.x and 23.x before 23.0.3, 23.x and 24.x before 24.1.3, and 25.x and 26.x before 26.1.0, there is a lack of checksum validation of supplied image_source URLs when configured to convert images to a raw format for streaming.
O3 Security · Impact-Aware SCA

Is CVE-2024-47211 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-47211: ironic — Fixed in 26.1.1