CVE-2025-44021 is a low-severity (CVSS 2.8) Path Traversal vulnerability in ironic. A fix is available for ironic — see the affected versions and patch details below.
OpenStack Ironic fails to restrict paths used for file:// image URLs
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-44021.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ironic🐍ironic🐍ironicReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ironic | all versions | 24.1.3pip install --upgrade 'ironic==24.1.3' |
| 🐍PyPI | ironic | ≥ 25.0.0&&< 26.1.1 | 26.1.1pip install --upgrade 'ironic==26.1.1' |
| 🐍PyPI | ironic | ≥ 27.0.0&&< 29.0.1 | 29.0.1pip install --upgrade 'ironic==29.0.1' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ironic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ironic to 24.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-44021 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2025-44021 in your dependencies?
Find it across PyPI, including transitive dependencies.