CVE-2026-40574 — oauth2-proxy
MEDIUMCVE-2026-40574 is a medium-severity (CVSS 6.8) CWE-863 vulnerability in github.com/oauth2-proxy/oauth2-proxy/v7. A fix is available for github.com/oauth2-proxy/oauth2-proxy/v7 — see the affected versions and patch details below.
OAuth2 Proxy has an Authorization Bypass in Email Domain Validation via Malformed Multi-@ Email Claims
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40574.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/oauth2-proxy/oauth2-proxy/v7Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An authorization bypass exists in OAuth2 Proxy as part of the email_domain enforcement option. An attacker may be able to authenticate with an email claim such as [email protected]@company.com and satisfy an allowed domain check for company.com, even though the claim is not a valid email address.
The issue ONLY affects deployments that rely on email_domain restrictions and accept email claim values from identity providers or claim mappings that do not strictly enforce normal email syntax. The practical risk ONLY exists in self-hosted or custom OIDC environments and federated setups where unexpected claim values can reach oauth2-proxy. Standard hosted providers that enforce valid email formatting ARE NOT effected.
Patches
Users should upgrade to v7.15.2 or later once available.
Workarounds
The most effective workaround is to ensure the configured identity provider cannot emit malformed or attacker-controlled email claim values.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/oauth2-proxy/oauth2-proxy/v7 | all versions | 7.15.2go get github.com/oauth2-proxy/oauth2-proxy/v7@v7.15.2 |
Affected Products
oauth2 proxyoauth2_proxy_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/oauth2-proxy/oauth2-proxy/v7, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/oauth2-proxy/oauth2-proxy/v7 to 7.15.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40574 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A Moderate impact authorization bypass flaw exists in OAuth2 Proxy affecting deployments configured with `email_domain` restrictions. This vulnerability allows a remote attacker to bypass these restrictions by crafting a malicious email claim, such as `[email protected]@company.com`, if the identity provider or claim…
To mitigate this issue, configure identity providers or claim mappings to strictly enforce normal email syntax for all email claim values. This prevents the acceptance of malformed email claims that could bypass `email_domain` restrictions. Red Hat recommends reviewing OAuth2 Proxy deployment configurations and associated identity providers to ensure robust email validation is in place.Source: Red Hat security advisory for CVE-2026-40574 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-40574 in your dependencies?
Find it across Go, including transitive dependencies.