CVE-2026-35554 is a high-severity (CVSS 8.7) CWE-362 vulnerability in org.apache.kafka:kafka-clients. A fix is available for org.apache.kafka:kafka-clients — see the affected versions and patch details below.
Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-35554.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kafka:kafka-clients☕org.apache.kafka:kafka-clients☕org.apache.kafka:kafka-clientsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A race condition in the Apache Kafka Java producer client’s buffer pool management can cause messages to be silently delivered to incorrect topics.
When a produce batch expires due to delivery.timeout.ms while a network request containing that batch is still in flight, the batch’s ByteBuffer is prematurely deallocated and returned to the buffer pool. If a subsequent producer batch—potentially destined for a different topic—reuses this freed buffer before the original network request completes, the buffer contents may become corrupted. This can result in messages being delivered to unintended topics without any error being reported to the producer.
Data Confidentiality: Messages intended for one topic may be delivered to a different topic, potentially exposing sensitive data to consumers who have access to the destination topic but not the intended source topic.
Data Integrity: Consumers on the receiving topic may encounter unexpected or incompatible messages, leading to deserialization failures, processing errors, and corrupted downstream data.
This issue affects Apache Kafka versions ≤ 3.9.1, ≤ 4.0.1, and ≤ 4.1.1.
Kafka users are advised to upgrade to 3.9.2, 4.0.2, 4.1.2, 4.2.0, or later to address this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kafka:kafka-clients | ≥ 2.8.0&&< 3.9.2 | 3.9.2org.apache.kafka:kafka-clients:3.9.2 |
| ☕Maven | org.apache.kafka:kafka-clients | ≥ 4.0.0&&< 4.0.2 | 4.0.2org.apache.kafka:kafka-clients:4.0.2 |
| ☕Maven | org.apache.kafka:kafka-clients | ≥ 4.1.0&&< 4.1.2 | 4.1.2org.apache.kafka:kafka-clients:4.1.2 |
Affected Products
kafkaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kafka:kafka-clients, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kafka:kafka-clients to 3.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-35554 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-35554 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Build of Apache Camel 4.14 for Quarkus 3.27 | kafka-clients | RHSA-2026:13631 |
| Red Hat build of Apache Camel 4.18.1 for Spring Boot 3.5.14 | kafka-clients | RHSA-2026:17668 |
| Red Hat build of Quarkus 3.27.3.SP1 | org.apache.kafka/kafka-clients:4.0.2.redhat-00001 | RHSA-2026:11721 |
| Red Hat JBoss Enterprise Application Platform 6.0.5.GA | org.apache.kafka/kafka-clients:3.9.2.redhat-00001 | RHSA-2026:42098 |
| Streams for Apache Kafka 3.2.1 | kafka-clients | RHSA-2026:54435 |
Frequently Asked Questions
Is CVE-2026-35554 in your dependencies?
Find it across Maven, including transitive dependencies.