CVE-2026-33558 — kafka-clients
MEDIUMCVE-2026-33558 is a medium-severity (CVSS 5.3) CWE-533 vulnerability in org.apache.kafka:kafka-clients. A fix is available for org.apache.kafka:kafka-clients — see the affected versions and patch details below.
Apache Kafka, Apache Kafka Clients: Information Exposure Through Network Client Log Output
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33558.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kafka:kafka-clients☕org.apache.kafka:kafka-clientsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Information exposure vulnerability has been identified in Apache Kafka.
The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are:
-
AlterConfigsRequest
-
AlterUserScramCredentialsRequest
-
ExpireDelegationTokenRequest
-
IncrementalAlterConfigsRequest
-
RenewDelegationTokenRequest
-
SaslAuthenticateRequest
-
createDelegationTokenResponse
-
describeDelegationTokenResponse
-
SaslAuthenticateResponse
This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kafka:kafka-clients | ≥ 0.11.0&&< 3.9.2 | 3.9.2org.apache.kafka:kafka-clients:3.9.2 |
| ☕Maven | org.apache.kafka:kafka-clients | ≥ 4.0.0&&< 4.0.1 | 4.0.1org.apache.kafka:kafka-clients:4.0.1 |
Affected Products
kafkaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kafka:kafka-clients, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kafka:kafka-clients to 3.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33558 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2026-33558 in your dependencies?
Find it across Maven, including transitive dependencies.