CVE-2017-12610 — kafka-clients
MEDIUMCVE-2017-12610 is a medium-severity (CVSS 6.8) Improper Authentication vulnerability in org.apache.kafka:kafka-clients. A fix is available for org.apache.kafka:kafka-clients — see the affected versions and patch details below.
Improper Authentication in Apache Kafka
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kafka:kafka-clients☕org.apache.kafka:kafka-clientsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Kafka 0.10.0.0 to 0.10.2.1 and 0.11.0.0 to 0.11.0.1, authenticated Kafka clients may use impersonation via a manually crafted protocol message with SASL/PLAIN or SASL/SCRAM authentication when using the built-in PLAIN or SCRAM server implementations in Apache Kafka.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kafka:kafka-clients | ≥ 0.10.0.0&&< 0.10.2.2 | 0.10.2.2org.apache.kafka:kafka-clients:0.10.2.2 |
| ☕Maven | org.apache.kafka:kafka-clients | ≥ 0.11.0.0&&< 0.11.0.2 | 0.11.0.2org.apache.kafka:kafka-clients:0.11.0.2 |
Affected Products
kafkaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kafka:kafka-clients, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kafka:kafka-clients to 0.10.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12610 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2017-12610 in your dependencies?
Find it across Maven, including transitive dependencies.